package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:www\.)?(?:domain1|domain2)\.com$`)
var str = `domain.com
domain1.com
domain2.com
ci.domain1.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}