$re = '/^(?:www\.)?(?:domain1|domain2)\.com$/m';
$str = 'domain.com
domain1.com
domain2.com
ci.domain1.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);