re = /^(?:www\.)?(?:domain1|domain2)\.com$/m
str = 'domain.com
domain1.com
domain2.com
ci.domain1.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end