#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^1\h+(?=\d(?:[^\d\n\r]?\d){9}$)"
Local $sString = "1 800-555-1111" & @CRLF & _
"" & @CRLF & _
"1 222-555-1111" & @CRLF & _
"" & @CRLF & _
"888-555-1111" & @CRLF & _
"" & @CRLF & _
"1 888 555 1111" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)