import re
regex = re.compile(r"^1\h+(?=\d(?:[^\d\n\r]?\d){9}$)", flags=re.MULTILINE)
test_str = ("1 800-555-1111\n\n"
"1 222-555-1111\n\n"
"888-555-1111\n\n"
"1 888 555 1111\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)