const regex = /All files[^|]*\|[^|]*\s+([\d\.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('All files[^|]*\\|[^|]*\\s+([\\d\\.]+)', 'g')
const str = `---------------------|----------|----------|----------|----------|----------------|
File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |
---------------------|----------|----------|----------|----------|----------------|
[32;1mAll files [0m |[32;1m 85.61[0m |[33;1m 59.85[0m |[32;1m 84.06[0m |[32;1m 87.14[0m |[31;1m [0m |
[32;1m cli [0m |[32;1m 95.37[0m |[33;1m 70.21[0m |[33;1m 76.47[0m |[32;1m 97.12[0m |[31;1m [0m |
[32;1m add.js [0m |[32;1m 100[0m |[32;1m 83.33[0m |[32;1m 100[0m |[32;1m 100[0m |[33;1m 12[0m |
---------------------|----------|----------|----------|----------|----------------|
File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |
---------------------|----------|----------|----------|----------|----------------|
All files | 85.61 | 59.85 | 84.06 | 87.14 | |
cli | 95.37 | 70.21 | 76.47 | 97.12 | |
add.js | 100 | 83.33 | 100 | 100 | 12 |
adduser.js | 100 | 83.33 | 100 | 100 | 21,23 |
new.js | 100 | 75 | 100 | 100 | 18,20 |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}