# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"All files[^|]*\|[^|]*\s+([\d\.]+)"
test_str = ("---------------------|----------|----------|----------|----------|----------------|\n"
"File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |\n"
"---------------------|----------|----------|----------|----------|----------------|\n"
"[32;1mAll files [0m |[32;1m 85.61[0m |[33;1m 59.85[0m |[32;1m 84.06[0m |[32;1m 87.14[0m |[31;1m [0m |\n"
"[32;1m cli [0m |[32;1m 95.37[0m |[33;1m 70.21[0m |[33;1m 76.47[0m |[32;1m 97.12[0m |[31;1m [0m |\n"
"[32;1m add.js [0m |[32;1m 100[0m |[32;1m 83.33[0m |[32;1m 100[0m |[32;1m 100[0m |[33;1m 12[0m |\n\n"
"---------------------|----------|----------|----------|----------|----------------|\n"
"File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |\n"
"---------------------|----------|----------|----------|----------|----------------|\n"
"All files | 85.61 | 59.85 | 84.06 | 87.14 | |\n"
" cli | 95.37 | 70.21 | 76.47 | 97.12 | |\n"
" add.js | 100 | 83.33 | 100 | 100 | 12 |\n"
" adduser.js | 100 | 83.33 | 100 | 100 | 21,23 |\n"
" new.js | 100 | 75 | 100 | 100 | 18,20 |")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.