const regex = /(?:google|googledrive)\.com\/.+([-\w]{25,})/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:google|googledrive)\\.com\\\/.+([-\\w]{25,})', 'mg')
const str = `https://docs.google.com/file/d/0B7o8Gc0zkYvNMnhCMUN6OEJBdms/preview?pli=1
https://drive.google.com/file/d/0B7ctSjjo70zWQ2YxZWI4Tkt1Qjg/view?usp=drive_web
https://drive.google.com/open?id=1Mthx54SjbISVvZQlnWuoLF1qGemeoMdxdA
https://docs.google.com/uc?id=0BzcYyGT1YDEZTi1JWGEzX01MYzQ&export=download
https://drive.google.com/a/fpt.edu.vn/uc?id=0B7WKZJxC-txXU0dzNzZob21vQ0E&export=download`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}