// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:google|googledrive)\.com\/.+([-\w]{25,})").unwrap();
let string = "https://docs.google.com/file/d/0B7o8Gc0zkYvNMnhCMUN6OEJBdms/preview?pli=1
https://drive.google.com/file/d/0B7ctSjjo70zWQ2YxZWI4Tkt1Qjg/view?usp=drive_web
https://drive.google.com/open?id=1Mthx54SjbISVvZQlnWuoLF1qGemeoMdxdA
https://docs.google.com/uc?id=0BzcYyGT1YDEZTi1JWGEzX01MYzQ&export=download
https://drive.google.com/a/fpt.edu.vn/uc?id=0B7WKZJxC-txXU0dzNzZob21vQ0E&export=download";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}