$re = '/(?:google|googledrive)\.com\/.+([-\w]{25,})/m';
$str = 'https://docs.google.com/file/d/0B7o8Gc0zkYvNMnhCMUN6OEJBdms/preview?pli=1
https://drive.google.com/file/d/0B7ctSjjo70zWQ2YxZWI4Tkt1Qjg/view?usp=drive_web
https://drive.google.com/open?id=1Mthx54SjbISVvZQlnWuoLF1qGemeoMdxdA
https://docs.google.com/uc?id=0BzcYyGT1YDEZTi1JWGEzX01MYzQ&export=download
https://drive.google.com/a/fpt.edu.vn/uc?id=0B7WKZJxC-txXU0dzNzZob21vQ0E&export=download';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);