using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:jake|donald|rita|katie)\b(?=[^\""]*(?:(?:\""[^\""]*){2})*\""[^\""]*$)";
string input = @"jack betty ""donald jake rita"" lorie katie danny ""katie""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}