import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:jake|donald|rita|katie)\\b(?=[^\\\"]*(?:(?:\\\"[^\\\"]*){2})*\\\"[^\\\"]*$)";
final String string = "jack betty \"donald jake rita\" lorie katie danny \"katie\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}