re = /\b(?:jake|donald|rita|katie)\b(?=[^\"]*(?:(?:\"[^\"]*){2})*\"[^\"]*$)/m
str = 'jack betty "donald jake rita" lorie katie danny "katie"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end