using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)(.+rary.+ring.+)(?=<)";
string input = @"<tag>
<tag>
not me please
</tag>
<tag>
arbitrary string
</tag>
</tag>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}