$re = '/(?<=>)(.+rary.+ring.+)(?=<)/s';
$str = '<tag>
<tag>
not me please
</tag>
<tag>
arbitrary string
</tag>
</tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);