import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)(.+rary.+ring.+)(?=<)";
final String string = "<tag>\n"
+ " <tag>\n"
+ " not me please\n"
+ " </tag>\n"
+ " <tag>\n"
+ " arbitrary string \n"
+ " </tag>\n"
+ "</tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}