#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[\p{L}\p{M}\p{Zs}]{2,30}$"
Local $sString = "Jan" & @CRLF & _
"Jim" & @CRLF & _
"John Mayer" & @CRLF & _
"John le Carré" & @CRLF & _
"Superman" & @CRLF & _
"S0perman" & @CRLF & _
"明美橋本" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")