$re = '/^[\p{L}\p{M}\p{Zs}]{2,30}$/um';
$str = 'Jan
Jim
John Mayer
John le Carré
Superman
S0perman
明美橋本
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);