// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)^[\p{L}\p{M}\p{Zs}]{2,30}$").unwrap();
let string = "Jan
Jim
John Mayer
John le Carré
Superman
S0perman
明美橋 本
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}