re = /([A-Za-z0-9]\w+\s\w+)+/m
str = 'Fares Alarabi Ahmed Algamdi Ibrahim Halawi Hossam Almalki Meshal Alshehri Mesleh Almansori Basel Almeshari Mohammed Alkhalifah '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end