$re = '/(?:[\(]|[\)]|[-])/m';
$str = '(204)555-5555';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;