package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{5}\s(\D+)`)
var str = `2 pièces - Rue Davioud 75016 Paris
2 pièces - Rue des Tilleuls 92100 Boulogne-Billancourt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}