$re = '/[0-9]{5}\s(\D+)/m';
$str = '2 pièces - Rue Davioud 75016 Paris
2 pièces - Rue des Tilleuls 92100 Boulogne-Billancourt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);