using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"событие\h(?:добавить|удалить|платеж)\h\[id(\d+)\|\@\D+(\d+)\K";
string input = @"событи е добавить [id5643543543|@username] [id2343243242|@user]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}