$re = '~событие\h(?:добавить|удалить|платеж)\h\[id(\d+)\|\@\D+(\d+)\K~m';
$str = 'событие добавить [id5643543543|@username] [id2343243242|@user]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);