re = /событие\h(?:добавить|удалить|платеж)\h\[id(\d+)\|\@\D+(\d+)\K/m
str = 'событие добавить [id5643543543|@username] [id2343243242|@user]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end