#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:(?:ftp|https?):\/\/|www\.)).+$"
Local $sString = "xxxx.xxxx.xxxx" & @CRLF & _
"ftp://www.xxzx.com/xxx.aspx" & @CRLF & _
"https://www.xxzx.com/xxx.aspx" & @CRLF & _
"http://xxxx.com" & @CRLF & _
"https://xxzx.com/xxx.aspx" & @CRLF & _
"http://www.xxxx.com" & @CRLF & _
"www.xxxx.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")