re = /^(?!(?:(?:ftp|https?):\/\/|www\.)).+$/m
str = 'xxxx.xxxx.xxxx
ftp://www.xxzx.com/xxx.aspx
https://www.xxzx.com/xxx.aspx
http://xxxx.com
https://xxzx.com/xxx.aspx
http://www.xxxx.com
www.xxxx.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end