const regex = /^(?!(?:(?:ftp|https?):\/\/|www\.)).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:(?:ftp|https?):\\\/\\\/|www\\.)).+$', 'gm')
const str = `xxxx.xxxx.xxxx
ftp://www.xxzx.com/xxx.aspx
https://www.xxzx.com/xxx.aspx
http://xxxx.com
https://xxzx.com/xxx.aspx
http://www.xxxx.com
www.xxxx.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}