#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(TASK.+)\s*({[\s\S]*})\s*void"
Local $sString = "TASK(arg1)" & @CRLF & _
"{" & @CRLF & _
" if (cond)" & @CRLF & _
" {" & @CRLF & _
" /* Comment */" & @CRLF & _
" function_call();" & @CRLF & _
" if(condIsTrue)" & @CRLF & _
" {" & @CRLF & _
" DoSomethingelse();" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" if (cond1)" & @CRLF & _
" {" & @CRLF & _
" /* Comment */" & @CRLF & _
" function_call1();" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"void FunctionIDoNotWant(void)" & @CRLF & _
"{" & @CRLF & _
" if (cond)" & @CRLF & _
" {" & @CRLF & _
" /* Comment */" & @CRLF & _
" function_call();" & @CRLF & _
" }" & @CRLF & _
" if (cond1)" & @CRLF & _
" {" & @CRLF & _
" /* Comment */" & @CRLF & _
" function_call1();" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")