re = /(TASK.+)\s*({[\s\S]*})\s*void/m
str = 'TASK(arg1)
{
if (cond)
{
/* Comment */
function_call();
if(condIsTrue)
{
DoSomethingelse();
}
}
if (cond1)
{
/* Comment */
function_call1();
}
}
void FunctionIDoNotWant(void)
{
if (cond)
{
/* Comment */
function_call();
}
if (cond1)
{
/* Comment */
function_call1();
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end