const regex = /(TASK.+)\s*({[\s\S]*})\s*void/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(TASK.+)\\s*({[\\s\\S]*})\\s*void', 'gm')
const str = `TASK(arg1)
{
if (cond)
{
/* Comment */
function_call();
if(condIsTrue)
{
DoSomethingelse();
}
}
if (cond1)
{
/* Comment */
function_call1();
}
}
void FunctionIDoNotWant(void)
{
if (cond)
{
/* Comment */
function_call();
}
if (cond1)
{
/* Comment */
function_call1();
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}