using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?!.*\bSTR1\b)(?=.*\bSTR2\b)";
string input = @"WORD0 STR1 WORD1 WORD2 WORD3
WORD4 WORD5 STR2 WORD6";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}