use strict;
my $str = 'WORD0 STR1 WORD1 WORD2 WORD3
WORD4 WORD5 STR2 WORD6';
my $regex = qr/\w+(?!.*\bSTR1\b)(?=.*\bSTR2\b)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}