import re
regex = re.compile(r"\w+(?!.*\bSTR1\b)(?=.*\bSTR2\b)", flags=re.MULTILINE | re.DOTALL)
test_str = ("WORD0 STR1 WORD1 WORD2 WORD3 \n"
"WORD4 WORD5 STR2 WORD6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")