const regex = /^\b(?>\.?\w+(?:\[\d+\])?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b(?>\\.?\\w+(?:\\[\\d+\\])?)+$', 'gm')
const str = `parent[0].child
parent.child
parent.child1.list[0].child2
parent[500].child
parent0.child
par50ent.child
parent[0].child1[20].child[0]
And some invalid examples are
parent..child
parent[].child
parent[1a].child
parent[a].child
.parent
parent.
I don't know much about regular expressions, so what I came up with is this following line:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}