$re = '/^\b(?>\.?\w+(?:\[\d+\])?)+$/m';
$str = 'parent[0].child
parent.child
parent.child1.list[0].child2
parent[500].child
parent0.child
par50ent.child
parent[0].child1[20].child[0]
And some invalid examples are
parent..child
parent[].child
parent[1a].child
parent[a].child
.parent
parent.
I don\'t know much about regular expressions, so what I came up with is this following line:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);