import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[(\\d](?:(?!\\h{2,})[-\\d()\\h])*\\d";
final String string = "555-555-5555 (555)555-5555 (555) 555-5555\n\n"
+ "However, if there's an extra space inside the string it does not find the phone. 555 -555-5555 (555)555- 5555 (555) 555 -5555";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}