use strict;
my $str = '555-555-5555 (555)555-5555 (555) 555-5555
However, if there\'s an extra space inside the string it does not find the phone. 555 -555-5555 (555)555- 5555 (555) 555 -5555';
my $regex = qr~[(\d](?:(?!\h{2,})[-\d()\h])*\d~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}