re = /[(\d](?:(?!\h{2,})[-\d()\h])*\d/
str = '555-555-5555 (555)555-5555 (555) 555-5555
However, if there\'s an extra space inside the string it does not find the phone. 555 -555-5555 (555)555- 5555 (555) 555 -5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end