#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)`{3}([\S\s]*?)`{3}|`([^`]*)`|~~([\S\s]*?)~~"
Local $sString = "Normal text, ~~this should be strikethrough~~ then some more normal text." & @CRLF & _
"" & @CRLF & _
"~~some multiline strikethrough " & @CRLF & _
"text here~~" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"Pre text." & @CRLF & _
"~~NOT strikethrough, nothing inside the code block should be matched/styled.~~" & @CRLF & _
"Post text." & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"`~~Not strikethrough either~~`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")