import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "`{3}([\\S\\s]*?)`{3}|`([^`]*)`|~~([\\S\\s]*?)~~";
final String string = "Normal text, ~~this should be strikethrough~~ then some more normal text.\n\n"
+ "~~some multiline strikethrough \n"
+ "text here~~\n\n"
+ "```\n"
+ "Pre text.\n"
+ "~~NOT strikethrough, nothing inside the code block should be matched/styled.~~\n"
+ "Post text.\n"
+ "```\n\n"
+ "`~~Not strikethrough either~~`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}