$re = '/`{3}([\S\s]*?)`{3}|`([^`]*)`|~~([\S\s]*?)~~/m';
$str = 'Normal text, ~~this should be strikethrough~~ then some more normal text.
~~some multiline strikethrough
text here~~
```
Pre text.
~~NOT strikethrough, nothing inside the code block should be matched/styled.~~
Post text.
```
`~~Not strikethrough either~~`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);