#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bhref="([^>]+)"
Local $sString = "<li><a href="Blah/Index.html">Blah</a></li>" & @CRLF & _
"<li><a href="/blah/Index.html">Blah</a></li>" & @CRLF & _
"<li><a href="../Blah/index.html">Blah</a></li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")