// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bhref="([^>]+)"#).unwrap();
let string = "<li><a href=\"Blah/Index.html\">Blah</a></li>
<li><a href=\"/blah/Index.html\">Blah</a></li>
<li><a href=\"../Blah/index.html\">Blah</a></li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}