using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhref=""([^>]+)";
string input = @"<li><a href=""Blah/Index.html"">Blah</a></li>
<li><a href=""/blah/Index.html"">Blah</a></li>
<li><a href=""../Blah/index.html"">Blah</a></li>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}