using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,|^)([^(,]*)\((\d*)\)(?=,|$)";
string input = @"math(5),English(6),P.E(5)
history(5),physics(6),art & craft (5)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}