$re = '/(?<=,|^)([^(,]*)\((\d*)\)(?=,|$)/m';
$str = 'math(5),English(6),P.E(5)
history(5),physics(6),art & craft (5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);