re = /(?<=,|^)([^(,]*)\((\d*)\)(?=,|$)/m
str = 'math(5),English(6),P.E(5)
history(5),physics(6),art & craft (5)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end