$re = '/Endine nimi\s*<\/td>\s*<td[^>]*>\s*(.*?)\s*<\/td>/s';
$str = 'Endine nimi </td>
<td >
MORENOL OÜ </td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);